Programar LibreOffice

From LibreOffice Help
Jump to: navigation, search

Puede asignar secuencias de órdenes personalizadas (macros) a elementos de menú, iconos, controles de diálogos y sucesos de LibreOffice.

LibreOffice admite los siguientes lenguajes de programación de secuencias de órdenes:

  1. LibreOffice Basic
  2. JavaScript
  3. BeanShell
  4. Python

Además, los desarrolladores pueden utilizar lenguajes de nivel alto, como por ejemplo Java, para controlar LibreOffice externamente. La referencia de la API está disponible en línea en api.libreoffice.org.

Para asignar una secuencia de órdenes a una entrada de menú nueva

  1. Seleccione Herramientas - Personalizar y haga clic en la ficha Menús.
  2. Haga clic en Agregar comandos.
  3. En el cuadro de lista Categoría, desplácese hacia abajo y abra la entrada "Macros de LibreOffice".
  4. Verá entradas para «Macros de LibreOffice» (secuencias de órdenes en la carpeta compartido de la instalación de LibreOffice), «Mis macros» (secuencias de órdenes en la carpeta del usuario) y el documento actual. Abra cualquiera de ellas para ver los lenguajes de programación admitidos.
  5. Abra cualquier entrada de lenguaje de programación para ver las secuencias de órdenes disponibles. Seleccione una.
  6. En el cuadro de lista Órdenes se incluye una lista de las funciones de secuencias de órdenes. Seleccione una.
  7. Haga clic en Agregar para crear una nueva asignación de menús. La nueva entrada de menú aparece en el cuadro de lista Entradas.

Para asignar una secuencia de órdenes a una combinación de teclas

  1. Elija Herramientas - Personalizar - Teclado.
  2. En el cuadro de lista Categoría, desplácese hacia abajo y abra la entrada "Macros de LibreOffice".
  3. Verá entradas para «Macros de LibreOffice» (secuencias de órdenes en la carpeta compartido de la instalación de LibreOffice), «Mis macros» (secuencias de órdenes en la carpeta del usuario) y el documento actual. Abra cualquiera de ellas para ver los lenguajes de programación admitidos.
  4. Abra cualquier entrada de lenguaje de programación para ver las secuencias de órdenes disponibles. Seleccione una.
  5. En el cuadro de lista Órdenes se incluye una lista de las funciones de secuencias de órdenes. Seleccione una.
  6. Haga clic en el botón de opción para LibreOffice o Writer (o la aplicación que esté abierta).

    Al seleccionar el botón de opción se configura el ámbito de aplicación de la nueva combinación de teclas en todo LibreOffice o sólo en los documentos del módulo actual.
  7. Seleccione una combinación de teclas del cuadro de lista Teclas de acceso directo y haga clic en Modificar.

Para asignar una secuencia de órdenes a un suceso

  1. Vaya a Herramientas ▸ Personalizar ▸ pestaña Sucesos.
  2. Pulse el botón Macro.
  3. En el cuadro de lista Biblioteca, desplácese hacia abajo y abra la entrada "Macros de LibreOffice".
  4. Verá entradas para «Macros de LibreOffice» (secuencias de órdenes en la carpeta compartido de la instalación de LibreOffice), «Mis macros» (secuencias de órdenes en la carpeta del usuario) y el documento actual. Abra cualquiera de ellas para ver los lenguajes de programación admitidos.
  5. Abra cualquier entrada de lenguaje de programación para ver las secuencias de órdenes disponibles. Seleccione una.
  6. En el cuadro de lista Acción asignada se incluye una lista de las funciones de secuencias de órdenes. Seleccione una.
  7. Seleccione para guardar en LibreOffice o el documento actual.

    Se configura el ámbito de aplicación de la nueva asignación de acción en todo LibreOffice o sólo en los documentos del módulo actual.
  8. Seleccione un suceso de la lista y pulse en Aceptar.

Para asignar una secuencia de órdenes a un suceso para un objeto incrustado

  1. Seleccione el objeto incrustado, por ejemplo un gráfico, en el documento.
  2. Elegir Formato - Marco/Objeto - Macro.
  3. En el cuadro de lista Macros, abra la entrada Secuencias de comandos de LibreOffice.
  4. Verá entradas para «share» (secuencias de órdenes en la carpeta compartida de la instalación de LibreOffice), «user» (secuencias de órdenes en la carpeta del usuario) y el documento actual. Abra cualquiera de ellas para ver los lenguajes de programación admitidos.
  5. Abra cualquier entrada de lenguaje de programación para ver las secuencias de órdenes disponibles. Seleccione una.
  6. En el cuadro de lista Macros existentes en se incluye una lista de las funciones de secuencias de órdenes. Seleccione una.
  7. Seleccione un suceso de la lista y pulse en Aceptar.

Para asignar una secuencia de órdenes a un hiperenlace

  1. Coloque el cursor en el hiperenlace.
  2. Vaya a Insertar ▸ Hiperenlace.
  3. Pulse en el botón Sucesos.
  4. Seleccione y asigne un estado de los anteriores.

Para asignar una secuencia de órdenes a un gráfico

  1. Seleccione el gráfico en el documento.
  2. Elija Formato ▸ Imagen ▸ Macro.
  3. Seleccione y asigne un estado de los anteriores.

Para asignar una secuencia de órdenes a un control de formulario

  1. Inserte un control de formulario, por ejemplo un botón: Abra la barra de herramientas Controles de formulario, pulse en el icono Botón y arrastre para abrir un botón en el documento.
  2. Con el control de formulario seleccionado, pulse en Control en la barra de herramientas Controles de formularios.
  3. Pulse en la pestaña Sucesos del cuadro de diálogo Propiedades.
  4. Pulse en uno de los botones para abrir un cuadro de diálogo donde asignar una secuencia de órdenes al suceso seleccionado.

Para asignar una secuencia de órdenes a un control de diálogo de LibreOffice Basic

  1. Abra el editor de diálogos de LibreOffice Basic y, a continuación, cree un diálogo con un control.
  2. Haga clic con el botón derecho en el control y seleccione Propiedades.
  3. Pulse en la pestaña Sucesos del cuadro de diálogo Propiedades.
  4. Pulse en uno de los botones para abrir un cuadro de diálogo donde asignar una secuencia de órdenes al suceso seleccionado.