Base でのデータのインポート/エクスポート

From LibreOffice Help
Jump to: navigation, search

データベーステーブルをインポートおよびエクスポートする簡単な方法としては、Calc を「ヘルパーアプリケーション」として使用します。

Base からのデータのエクスポート

Base から新しい Calc シートにテーブルをコピーしてから、そのデータを保存またはエクスポートしたり、Calc がサポートする任意のファイル形式にデータをエクスポートできます。

  1. エクスポートするデータベーステーブルが含まれるデータベースファイルを開きます。 「テーブル」をクリックしてテーブルを表示するか、「クエリー」をクリックしてクエリーを表示します。
  2. 「ファイル」 → 「新規作成」 → 「表計算」 を選択します。
  3. Base ウィンドウで、エクスポートするテーブルの名前を右クリックします。 コンテキストメニューから 「コピー」 を選択します。
  4. 新しい Calc ウィンドウでセル A1 をクリックしてから 「編集」 → 「貼り付け」 を選択します。

これでデータを保存したり、データを多くのファイルの種類にエクスポートすることができます。

Base へのデータのインポート

Note.png テキストファイル、表計算ファイル、およびシステムのアドレス帳は、読み取り専用でのみインポートできます。
Note.png テキストまたは表計算ファイルからインポートする場合、ファイルの最初の行にヘッダー情報が必要です。ファイルの 2 行目が最初の有効なデータ行になります。2 行目の各フィールドの形式によって、列全体の形式が決まります。Base にインポートすると、表計算ファイルの形式情報が失われます。
Note.png たとえば、最初の列をテキスト形式にするには、必ず最初の有効なデータ列の最初のフィールドにテキストを入れてください。最初の有効なデータ行に数字が含まれる場合、列全体が数字形式に設定され、その列には数字だけが表示されて、テキストは表示されません。
  1. 必要なデータベースの種類の Base ファイルを開きます。

    データベースウィザードを使用して新しい Base ファイルを作成するか、読み取り専用ではない既存の Base ファイルを開きます。
  2. Base にインポートするデータを含む Calc ファイルを開きます。*.dbf dBASE ファイルまたはほかの多くのファイルタイプを開くことができます。
  3. Base にコピーするデータを選択します。

    スクロールしたくない場合は、名前 ボックスに「A1:X500」のような範囲参照を入力できます。

    dBASE シートをコピーする場合、ヘッダーデータを含む最上行を含めます。
  4. 「編集」 → 「コピー」 を選択します。
  5. テーブルを表示するには、Base ウィンドウで 「テーブル」 をクリックします。
  6. Base ウィンドウで 「編集」 → 「貼り付け」 を選択します。
  7. テーブルの「コピー」ダイアログが表示されます。 ほとんどのデータベースはプライマリキーが必要なので、「プライマリキーの作成」 ボックスをオンにする必要があります。
Tip.png Windows システムでは、コピー&ペーストの代わりにドラッグ&ドロップも使用できます。 また、登録済みデータベースでは、Base ウィンドウを開く代わりにデータソース表示 (F4 を押す) を使用することもできます。

Related Topics

データベースを LibreOffice Base で使用

データソースの概要

dBASE ファイルのインポートとエクスポート

テキスト CSV ファイルのオープンと保存