General Shortcut Keys in LibreOffice

From LibreOffice Help
Jump to: navigation, search
Note.png Some of the shortcut keys may be assigned to your desktop system. Keys that are assigned to the desktop system are not available to LibreOffice. Try to assign different keys either for LibreOffice, in Tools - Customize - Keyboard, or in your desktop system.

Using Shortcut Keys

A great deal of your application's functionality can be called up by using shortcut keys. For example, the Ctrl+O shortcut keys are shown next to the Open entry in the File menu. If you want to access this function by using the shortcut keys, press and hold down Ctrl and then press the O key. Release both keys after the dialog appears.

When operating your application, you can choose between using the mouse or the keyboard for almost all of the operations available.

Calling Menus With Shortcut Keys

Some of the characters shown on the menu bar are underlined. You can access these menus directly by pressing the underlined character together with the ALT key. Once the menu is opened, you will again find underlined characters. You can access these menu items directly by simply pressing the underlined character key.

Using Shortcut Keys to Control Dialogs

There is always one element highlighted in any given dialog - usually shown by a broken frame. This element, which can be either a button, an option field, an entry in a list box or a check box, is said to have the focus on it. If the focal point is a button, pressing Enter runs it as if you had clicked it. A check box is toggled by pressing the spacebar. If an option field has the focus, use the arrow keys to change the activated option field in that area. Use the Tab key to go from one element or area to the next one, use Shift+Tab to go in the reverse direction.

Pressing ESC closes the dialog without saving changes. If you place the focus on a button, not only will you see the dotted line framing the name of the button, but also a thicker shadow under the button selected. This indicates that if you exit the dialog by pressing the Enter key, it is the equivalent of pressing that button itself.

Shortcut Keys for Mouse Actions

If you are using drag-and-drop, selecting with the mouse or clicking objects and names, you can use the keys Shift, Ctrl and occasionally Alt to access additional functionality. The modified functions available when holding down keys during drag-and-drop are indicated by the mouse pointer changing form. When selecting files or other objects, the modifier keys can extend the selection - the functions are explained where applicable. The availability of this function depends on your X Window Manager.

Practical Text Input Fields

  1. You can open a context menu, which contains some of the most often-used commands.
  2. Use the shortcut keys Ctrl+Shift+S to open the Special Characters dialog to insert one or more special characters.
  3. Use Ctrl+A to select the entire text. Use the right or left arrow key to remove the selection.
  4. Double-click a word to select it.
  5. A triple-click in a text input field selects the entire field. A triple-click in a text document selects the current sentence.
  6. Use Ctrl+Del to delete everything from the cursor position to the end of the word.
  7. By using Ctrl and right or left arrow key, the cursor will jump from word to word; if you also hold down the Shift key, one word after the other is selected.
  8. INSRT is used to switch between the insert mode and the overwrite mode and back again.
  9. Drag-and-drop can be used within and outside of a text box.
  10. The Ctrl+Z shortcut keys are used to undo modifications one step at a time; the text will then have the status it had before the first change.
  1. LibreOffice has an AutoComplete function which activates itself in some text and list boxes. For example, enter ~/a into the URL field and the AutoComplete function displays the first file or first directory found in your home folder that starts with the letter "a".
  2. Use the down arrow key to scroll through the other files and directories. Use the right arrow key to also display an existing subdirectory in the URL field. Quick AutoComplete is available if you press the End key after entering part of the URL. Once you find the document or directory you want, press Enter.

Interrupting Macros

If you want to terminate a macro that is currently running, press Ctrl+Shift+Q.

List of General Shortcut Keys in LibreOffice

The shortcut keys are shown on the right hand side of the menu lists next to the corresponding menu command.

Shortcut keys for controlling dialogs

Shortcut Keys Effect
Enter key Activates the focused button in a dialog
Esc Terminates the action or dialog. If in LibreOffice Help: goes up one level.
Spacebar Toggles the focused check box in a dialog.
Arrow keys Changes the active control field in an option section of a dialog.
Tab Advances focus to the next section or element in a dialog.
Shift+Tab Moves the focus to the previous section or element in a dialog.
Alt+Down Arrow Opens the list of the control field currently selected in a dialog. These shortcut keys apply not only to combo boxes but also to icon buttons with pop-up menus. Close an opened list by pressing the Escape key.

Shortcut keys for controlling documents and windows

Shortcut Keys Effect
Ctrl+O Opens a document.
Ctrl+S Saves the current document.
Ctrl+N Creates a new document.
Ctrl+Shift+N Opens Templates and Documents dialog.
Ctrl+P Prints document.
Ctrl+F Activates the Find toolbar.
Ctrl+H Calls the Find & Replace dialog.
Ctrl+Shift+F Searches for the last entered search term.
Ctrl+Shift+J Toggles the view between fullscreen mode and normal mode in Writer or Calc
Ctrl+Shift+R Redraws the document view.
Ctrl+Shift+I Enable or disable the selection cursor in read-only text.
F1 Starts the LibreOffice Help

In the LibreOffice Help: jumps to main help page.

Shift+F1 Context Help
Shift+F2 Turns on Extended Tips for the currently selected command, icon or control.
F6 Sets focus in next subwindow (for example, document/data source view)
Shift+F6 Sets focus in previous subwindow.
F10 Activates the first menu (File menu)
Shift+F10 Opens the context menu.
Ctrl+F4 or Alt+F4 Closes the current document (close LibreOffice when the last open document is closed)
Ctrl+Q Exits application.

Shortcut keys for editing or formatting documents

Shortcut Keys Effect
Ctrl+Tab When positioned at the start of a header, a tab is inserted.
Enter (if an OLE object is selected) Activates the selected OLE object.
Enter (if a drawing object or text object is selected) Activates text input mode.
Ctrl+X Cuts out the selected elements.
Ctrl+C Copies the selected items.
Ctrl+V Pastes from the clipboard.
Ctrl+Alt+Shift+V Pastes unformatted text from the clipboard. The text is pasted using the format that exists at the insertion point.
Ctrl+Shift+V Opens the Paste Special dialog.
Ctrl+A Selects all.
Ctrl+Z Undoes last action.
Ctrl+Y Redoes last action.
Ctrl+Shift+Y Repeats last command.
Ctrl+I The Italic attribute is applied to the selected area. If the cursor is positioned in a word, this word is also marked in italic.
Ctrl+B The Bold attribute is applied to the selected area. If the cursor is positioned in a word, this word is also put in bold.
Ctrl+U The Underlined attribute is applied to the selected area. If the cursor is positioned in a word, this word is also underlined.
Ctrl+M Removes direct formatting from selected text or objects (as in Format - Clear Direct Formatting)

Shortcut keys in the Gallery

Shortcut keys Result
Tab Moves between areas.
Shift+Tab Moves between areas (backwards)

Shortcut keys in the New Theme area of the Gallery:

Shortcut keys Result
Up Arrow Moves the selection up one.
Down Arrow Moves the selection down.
Ctrl+Enter Opens the Properties dialog.
Shift+F10 Opens a context menu.
Ctrl+U Refreshes the selected theme.
Ctrl+R Opens the Enter Title dialog.
Ctrl+D Deletes the selected theme.
Insert Inserts a new theme

Shortcut keys in the Gallery preview area:

Shortcut keys Result
Home Jumps to the first entry.
End Jumps to the last entry.
Left Arrow Selects the next Gallery element on the left.
Right Arrow Selects the next Gallery element on the right.
Up Arrow Selects the next Gallery element above.
Down Arrow Selects the next Gallery element below.
Page Up Scroll up one screen.
Page Down Scroll down one screen.
Ctrl+Shift+Insert Inserts the selected object as a linked object into the current document.
Ctrl+I Inserts a copy of the selected object into the current document.
Ctrl+T Opens the Enter Title dialog.
Ctrl+P Switches between themes view and object view.
Spacebar Switches between themes view and object view.
Enter Switches between themes view and object view.
Step backward (only in object view) Switches back to main overview.

Selecting Rows and Columns in a Database Table (opened by F4)

Shortcut keys Result
Spacebar Toggles row selection, except when the row is in edit mode.
Ctrl+Spacebar Toggles row selection
Shift+Spacebar Selects the current column
Ctrl+Page Up Moves pointer to the first row
Ctrl+Page Down Moves pointer to the last row

Shortcut Keys for Drawing Objects

Shortcut keys Result
Select the toolbar with F6. Use the Down Arrow and Right Arrow to select the desired toolbar icon and press Ctrl+Enter Inserts a Drawing Object.
Select the document with Ctrl+F6 and press Tab Selects a Drawing Object.
Tab Selects the next Drawing Object.
Shift+Tab Selects the previous Drawing Object.
Ctrl+Home Selects the first Drawing Object.
Ctrl+End Selects the last Drawing Object.
Esc Ends Drawing Object selection.
Esc (in Handle Selection Mode) Exit Handle Selection Mode and return to Object Selection Mode.
Up/Down/Left/Right Arrow Move the selected point (the snap-to-grid functions are temporarily disabled, but end points still snap to each other).
Alt+Up/Down/Left/Right Arrow Moves the selected Drawing Object one pixel (in Selection Mode)

Re-sizes a Drawing Object (in Handle Selection Mode)

Rotates a Drawing Object (in Rotation Mode)

Opens the properties dialog for a Drawing Object.

Activates the Point Selection mode for the selected drawing object.

Spacebar Select a point of a drawing object (in Point Selection mode) / Cancel selection.

The selected point blinks once per second.

Shift+Spacebar Select an additional point in Point Selection mode.
Ctrl+Tab Select the next point of the drawing object (Point Selection mode)

In Rotation mode, the center of rotation can also be selected.

Ctrl+Shift+Tab Select the previous point of the drawing object (Point Selection mode)
Ctrl+Enter A new drawing object with default size is placed in the center of the current view.
Ctrl+Enter at the Selection icon Activates the first drawing object in the document.
Esc Leave the Point Selection mode. The drawing object is selected afterwards.

Edit a point of a drawing object (Point Edit mode)

Any text or numerical key If a drawing object is selected, switches to edit mode and places the cursor at the end of the text in the drawing object. A printable character is inserted.
Alt key while creating or scaling a graphic object The position of the object's center is fixed.
Shift key while creating or scaling a graphic object The ratio of the object's width to height is fixed.

Related Topics

Database Shortcut Keys

Shortcuts (LibreOffice Accessibility)