Generell ordliste

From LibreOffice Help
Jump to: navigation, search

Denne ordlista forklarer en del av de vanligste uttrykkene du finner i LibreOffice.

Du kan bruke ordlista til å slå opp ukjente ord som du finner i LibreOffice-programmene.

Tallsystem

Tallsystemer er inndelt etter hvor mange tegn de bruker til å representere tall. Desimalsystemet er for eksempel basert på tallene fra 0 til 9, binærsystemet på tallene 0 og 1, og det heksadesimale systemet er basert på 16 tegn (0-9 og A-F).

Lenke

Kommandoen Lenker ligger i Rediger-menyen. Denne kommandoen kan bare brukes når det finnes minst en lenke i dokumentet. Når du setter inn et objekt, for eksempel et bilde, kan du enten kopiere det inn i dokumentet eller sette det inn som en lenke.

Hvis et objekt settes direkte inn i et dokument, øker størrelsen på dokumentfila med minst størrelsen på objektet. Når du lagrer dokumentet og åpner det på en annen maskin, vil objektet du satte inn, fremdeles ligge på samme sted i dokumentet.

Dersom du setter inn objektet som en lenke, er det bare en referanse til filnavnet som blir satt inn. Størrelsen på dokumentfila øker nesten ikke i det hele. Nå kan du derimot ikke åpne dokumentet på en annen maskin uten at den lenkede fila ligger på nøyaktig samme sted der også.

Bruk Rediger → Lenker for å se hvilke filer som er satt inn som lenker. Du kan fjerne lenkene hvis du vil det. I så fall brytes lenka, og objektet settes inn direkte.

SQL-database / SQL-tjener

En SQL-database er et databasesystem som gir et SQL-grensesnitt. SQL-databaser blir brukt i klient/tjener-nettverk der flere klienter har tilgang til en sentral tjener. Derfor blir slike databaser ofte kalt SQL-tjenerdatabaser eller bare SQL-tjenere.

Du kan integrere eksterne SQL-databaser i LibreOffice. Databasene kan enten ligge lokalt på din egen harddisk eller et annet sted i nettverket. Tilgangen skjer enten gjennom ODBC eller gjennom drivere som er innebygd i LibreOffice.

SQL

SQL («Structured Query Language») er et språk som blir brukt til databasespørringer. I LibreOffice kan du lage spørringer både i SQL og interaktivt med musa.

Lagre relativt og absolutt

I flere dialogvinduer (for eksempel Rediger → Autotekst) kan du velge om filer skal lagres relativt eller absolutt.

Hvis du velger å lagre relativt, blir referansene til innebygde bilder eller andre objekter i dokumentet, lagret relativt til plasseringa i filsystemet. Da vil det ikke ha noe å si hvor mappestrukturen det refereres til, faktisk ligger. Filene vil bli funnet uansett hvor de ligger, så lenge det refereres til samme stasjon eller volum. Dette er viktig å huske hvis du vil gjøre dokumentet tilgjengelig for andre datamaskiner der mappestrukturen og navn på stasjoner og volumer kan være helt annerledes. Det er også lurt å lagre relativt hvis du skal lage en mappestruktur på en Internett-tjener.

Hvis du heller vil lagre absolutt, vil alle referanser til andre filer også være absolutte i forhold til stasjonen, volumet eller rotmappa der filene ligger. Fordelen med dette er at selve dokumentet som inneholder referansene, kan flyttes til andre mapper uten at referansene blir ugyldige.

Enker og faderløse

«Enker» og «faderløse» er uttrykk med lang typografisk tradisjon. Enker er korte linjer på slutten av avsnitt, som havner alene på toppen av neste side som skrives ut. Linjer er faderløse når den første linja i et avsnitt skrives ut alene nederst på forrige side. I LibreOffice kan du automatisk hindre at slike linjer finnes i tekstdokumenter ved hjelp av en innstilling i avsnittsstilen. Der kan du selv velge hvor mange linjer du vil holde samla på en side.

RTF

RTF («Rich Text Format») er et filformat som er tilpasset utveksling av tekstfiler. En spesiell funksjon er at formateringa blir gjort om til direkte lesbar tekstinformasjon. Dessverre gir RTF gjerne større filer enn andre filformater.

Relasjonsdatabase

En relasjonsdatabase er en samling dataelementer som er organiserte som et sett formelt beskrevet tabeller, der data kan hentes ut eller settes sammen på mange ulike måter uten at selve tabellene må omorganiseres.

Et relasjonsdatabasesystem (RDBMS) er et program som lar deg lage, oppdatere og styre relasjonsdatabaser gjennom SQL-uttrykk fra brukeren eller et program.

Et godt eksempel på en relasjonsdatabase kan være en database med tabellene «Kunde», «Innkjøp» og «Faktura». I fakturatabellen ligger det ingen data om kunder eller innkjøp, bare referanser (relasjoner) til de aktuelle feltene i kunde- og innkjøpstabellene (for eksempel feltet Kunde-ID fra kundetabellen).

Sett i kegel

Sett i kegel er et typografisk uttrykk som blir brukt ved utskrift. Uttrykket viser til lik plassering av linjene på framsiden og baksiden av arket. Da blir sidene lettere å lese, siden en unngår at grå skygger vises gjennom arket mellom linjene. Funksjonen sørger også for at linjer i spalter som ligger ved siden av hverandre får samme høyde.

Når et avsnitt, en avsnittsstil eller en sidestil settes i kegel, blir grunnlinjene til tegnene justert etter et fast, loddrett rutenett, uansett hvor stor skrifta er eller om det er bilder i teksten. Hvis du vil, kan du tilpasse innstillingene til rutenettet som en egenskap ved sidestilen.

Primærnøkkel

En primærnøkkel tjener som entydig identifikasjon av databasefelter. Den unike identifikasjonen blir brukt i relasjonsdatabaser for å hente data fra andre tabeller. Referanser til primærnøklar fra andre tabeller blir kalt framandnøklar.

I LibreOffice velger du primærnøkkelen i utformingsvisninga av en tabell ved å velge den aktuelle kommandoen fra sprettoppmenyen i radoverskrifta til det valgte feltet.

PNG

PNG («Portable Network Graphics») er et bildefilformat. Filene komprimeres med en selvvalgt komprimeringsfaktor, og i motsetning til JPG-formatet, komprimeres alltid PNG-filer uten tap av informasjon.

OpenGL

OpenGL er et språk for 3D-grafikk, opprinnelig utviklet av SGI (Silicon Graphics Inc.). Det finnes to varianter i vanlig bruk: Microsoft OpenGL som er utviklet for bruk i Windows NT, og Cosmo OpenGL som er laget av SGI. Den siste er et uavhengig grafikkspråk for alle plattformer og alle slags datamaskiner, til og med maskiner som ikke har spesiell maskinvare for 3D-grafikk.

OLE

OLE-objekt («Object Linking and Embedding») kan lenkes eller bygges inn i dokument. Innebygde objekter er kopiert inn sammen med detaljer om opphavsprogrammet. Dersom du vil redigere objektet, kan du enkelt starte opphavsprogrammet ved å dobbeltklikke på objektet.

ODBC

«Open Database Connectivity» er en vanlig protokoll som programmer kan bruke til å snakke med databaser. Spørrespråket er SQL («Structured Query Language»). I LibreOffice kan du velge for hver enkelt database om SQL-kommandoer skal brukes til spørringer. Alternativet er å lage spørringer i det interaktive grensesnittet, slik at LibreOffice etterpå kan oversette dem til SQL for deg.


Objekt

Et objekt er et skjermelement som inneholder data. Det kan vise til data fra andre programmer, for eksempel tekst eller bilder.

Objekter er uavhengige og påvirker ikke hverandre. Alle objekter som inneholder data kan tilordnes visse kommandoer. For eksempel har et bildeobjekt kommandoer for bilderedigering, mens et regneark har regnekommandoer.

Sprettoppmeny

Du kan åpne sprettoppmenyen til et objekt ved å trykke på det med venstre museknapp for å velge det, og så klikke med høyre museknapp. Noen sprettoppmenyer kan åpnes selv om objektet ikke er valgt. Du finner sprettoppmenyer overalt i LibreOffice.

Kerning

Kerning vil si å gjøre avstanden mellom tegnpar større eller mindre slik at teksten totalt sett ser bedre ut.

Kerningstabellene inneholder informasjon om hvilke tegnpar som krever tilpasset avstand. Slike tabeller er vanligvis innebygde i skriftene.

JDBC

Med JDBC («Java Database Connectivity») kan du koble til databaser fra LibreOffice. JDBC-driverne er skrevet i programmeringsspråket Java og er plattformuavhengige.

Formatering

Formatering er den visuelle utforminga av teksten i en tekstbehandler eller et datatrykkeprogram. Dette omfatter papirformat, sidemarger, skrifter, skrifteffekter, innrykk, mellomrom og mye annet. Du kan formatere tekst direkte eller med stiler fra LibreOffice.

Rulleknapp

  1. I skjemakontroller er en rulleknapp en egenskap for et tallfelt, valutafelt, datofelt eller klokkeslettfelt. Hvis egenskapen «Rulleknapp» er slått på, viser feltet et par symboler med piler som peker i motsatt retning, enten vannrett eller loddrett.
  2. I Basic-IDE er rulleknapp navnet som brukes på det numeriske feltet og de to pilsymbolene.

Du kan skrive inn et tall i det numeriske feltet ved siden av rulleknappen, eller du kan velge en verdi ved å trykke pil opp eller pil ned på rulleknappen. Det går også an å trykke piltastene på tastaturet for å øke og minske verdien. Med «Page Up» og «Page Down» kan du hoppe rett til den største eller den minste verdien som kan brukes.

Hvis feltet ved siden av rulleknappen brukes til å velge numerske verdier, kan du også velge måleenhet, for eksempel 1 cm eller 5 mm, 12 pt eller 2"

DDE

DDE står for «Dynamic Data Exchange», og er en forgjenger til OLE, «Object Linking and Embedding». Med DDE kan objekter legges inn som fillenker, men ikke bygges inn i dokumentene.

Du kan lage DDE-lenker på følgende måte: Velg celler fra et Calc-regneark, kopier de til utklippstavla og bytt til et annet regneark der du velger Rediger → Lim inn utvalg. Velg Lenke for å sette inn cellene som en DDE-lenke. Celleområdet blir da lest inn fra originalfila.

Kompleks tekstutforming (KTO)

Språk med kompleks tekstutforming kan ha noen eller alle de følgende egenskapene:

  • Språket blir skrevet med tegn som er satt sammen av flere deler.
  • Teksten blir skrevet fra høyre til venstre.

LibreOffice støtter i dag hindi, thai, hebraisk og arabisk som KTO-språk.

Du kan slå på CTL-støtte i Verktøy → Innstillinger' → Språkinnstillinger → Språk'.

Bézier-objekt

Den franske matematikeren Pierre Bézier utviklet en måte å beskrive kurver på matematisk. Tegneprogram bruker ofte Bézier-kurver i todimensjonale tegninger. Kurven er styrt av fire punkter: Start- og sluttposisjonen, pluss to mellompunkt. Når du endrer på Bézier-objekter, flytter du disse punktene med musa.

ASCII

Forkorting for «American Standard Code for Information Interchange». ASCII er et tegnsett for framvisning av skrift på datamaskiner. Det inneholder 128 bokstaver, tall og andre tegn. Det utvidede ASCII-tegnsettet inneholder 256 tegn. Hvert tegn har sitt eget nummer, ofte kalt ASCII-kode.

I nettsider kan du ofte bare bruke 7-bits ASCII-tegn. Andre tegn, for eksempel æ, ø og å, må skrives inn med spesielle koder. Når du skriver inn tegn fra det utvidede ASCII-tegnsettet, gjør eksportfilteret i LibreOffice om slike tegn automatisk.

Festing av vindu

Noen vinduer i LibreOffice, for eksempel "Stiler og formatering" og dokumentstruktur, kan limes inn. Du kan flytte disse vinduene, endre størrelsen på de eller klistre de til en kant. Til hver kant kan du lime inn flere vinduer over og under hverandre eller ved siden av hverandre. Du kan endre størrelsen på vinduene ved å dra i rammene.

Dobbeltklikk i et tomt område i vinduet mens du holder nede Ctrl-tasten for å frigjøre eller feste vindauet igjen. I vinduet for stiler og formatering kan du også dobbeltklikke i den grå delen av vinduet ved siden av ikonet mens du holder nede Ctrl-tasten.

Festing (automatisk skjuling)

Ved de vinduskantene der et vindu er festet, kan du se en knapp som du kan bruke til å vise eller skjule vinduet.

  • Dersom du trykker på knappen ved vinduskanten for å vise vinduet, holder vinduet seg synlig helt til du skjuler det igjen med den samme knappen.
  • Dersom du henter fram vinduet ved å klikke på vinduskanten i stedet for å bruke knappen, vil det bli automatisk skjult igjen. Denne funksjonen lar deg vise et skjult vindu en liten stund. Når du klikker i dokumentet, blir vinduet skjult igjen.

Formatering direkte og med stiler

Hvis du formaterer et dokument uten å bruke stiler, bruker du det vi kaller «direkte» formatering. Det vil si at du endrer tekst eller andre objekter, for eksempel rammer eller tabeller, ved å velge forskjellige egenskaper direkte. Formatet gjelder bare for det valgte området, så alle endringer må gjøres hver for seg. Stiler, derimot, brukes ikke direkte i teksten, men må i stedet velges ved hjelp av stilbehandleren før de tas i bruk. En av fordelene stiler gir, er at når du gjør endringer i en stil, tas endringene i bruk samtidig i alle deler av dokumentet der denne stilen er i bruk.

Du kan fjerne direkte formatering fra dokumentet ved å markere all tekst med snarveien Ctrl + A og deretter velge Formater → Fjern direkte formatering.

Skrivemetode

En «skrivemetode» er et hjelpeprogram som kan brukes om du vil skrive inn komplekse tegn fra ikke-vestlige tegnsett med et vanlig tastatur.