Allgemeines Glossar

From LibreOffice Help
Jump to: navigation, search

Um Ihnen den Start mit dem LibreOffice zu erleichtern, erklären wir für Sie in diesem Glossar die wichtigsten Fachbegriffe, auf die Sie immer wieder stoßen.

Zur Suche nach unbekannten Begriffen in einer LibreOffice-Anwendung verwenden Sie das Glossar.

Zahlensystem

Ein Zahlensystem ist durch die Anzahl der zur Darstellung von Zahlen verfügbaren Zeichen gekennzeichnet. So basiert beispielsweise das Dezimalsystem auf zehn Ziffern (0 bis 9), das Binär- oder Dualzahlensystem auf zwei Ziffern (0 und 1) und das Hexadezimalsystem auf 16 Zeichen (0 bis 9 und A bis F).

Verknüpfung

Das Menü Bearbeiten enthält den Befehl Verknüpfungen. Er ist nur in Dokumenten aktivierbar, die mindestens eine Verknüpfung aufweisen. Beim Einfügen z. B. eines Bildes können Sie das Bild direkt oder als Verknüpfung in das Dokument einfügen.

Beim direkten Einfügen in das Dokument erhöht sich die Dokumentgröße um (mindestens) die Größe des Objekts in Byte. Sie können das Dokument speichern und auf einem anderen Rechner öffnen und das eingefügte Objekt ist immer noch an seiner Stelle im Dokument vorhanden.

Fügen Sie das Objekt als Verknüpfung ein, so wird nur eine Referenz auf den Dateinamen eingefügt. Die Dateigröße des Dokuments erhöht sich nur um diese Pfad- und Dateiangabe. Öffnen Sie Ihr Dokument allerdings auf einem anderen Rechner, so muss sich die verknüpfte Datei wieder an genau der Stelle befinden, die der Referenz entspricht, damit das Objekt im Dokument zu sehen ist.

Im Dialog Bearbeiten - Verknüpfungen können Sie feststellen, welche Dateien als Verknüpfung in Ihrem Dokument enthalten sind. Auf Wunsch können Sie hier auch die Verknüpfungen lösen. Beim Lösen einer Verknüpfung wird das Objekt direkt in das Dokument eingefügt.

SQL-Datenbank / SQL-Server

Eine SQL-Datenbank ist ein Datenbanksystem, das eine SQL-Schnittstelle bietet. SQL-Datenbanken werden oft in Client/Server-Netzwerken eingesetzt, in denen verschiedene Clients auf einen zentralen Server (z. B. einen SQL-Server) zugreifen, daher bezeichnet man sie auch als SQL-Server-Datenbanken oder kurz SQL-Server.

In LibreOffice können Sie externe SQL-Datenbanken einbinden. Diese können sich sowohl auf einer Festplatte des Rechners, auf dem LibreOffice läuft, als auch im Netzwerk befinden. Der Zugriff erfolgt entweder über ODBC, JDBC oder über einen in LibreOffice integrierten systemeigenen Treiber.

SQL

SQL (Structured Query Language) ist eine Sprache zur Spezifikation von Datenbankabfragen. In LibreOffice haben Sie die Möglichkeit, Abfragen entweder in SQL oder mithilfe der Maus zu definieren.

Relativ und absolut speichern

In einigen Dialogen (z.B. Extras - AutoText...) können Sie wählen, ob eine Datei relativ oder absolut gespeichert werden soll.

Wenn Sie sich für das relative Speichern entscheiden, werden Referenzen auf eingebettete Grafiken oder andere Objekte im Dokument relativ zur Position im Dateisystem gespeichert. In diesem Fall spielt es keine Rolle, wo die referenzierte Verzeichnisstruktur eingetragen ist. Solange die Referenz auf derselben Festplatte bzw. demselben Volume bleibt, werden die Dateien unabhängig vom Speicherort immer aufgefunden. Dies ist für solche Dokumente von besonderer Bedeutung, die auch auf Computern mit einer möglicherweise ganz anderen Verzeichnisstruktur oder anderen Laufwerks- oder Volume-Namen verwendet werden sollen. Auch für das Anlegen von Verzeichnisstrukturen auf einem Internetserver empfiehlt es sich, Dokumente relativ zu speichern.

Wenn Sie absolut speichern, werden alle Referenzen auf andere Dateien ebenfalls als absolut definiert, wobei sich diese Definition am jeweiligen Laufwerk, Volume oder Quellverzeichnis orientiert. Der Vorteil dieser Methode besteht darin, dass das Dokument mit den Referenzen in ein anderes Verzeichnis oder einen anderen Ordner verschoben werden kann und die Referenzen weiterhin gültig bleiben.

Schusterjungen und Hurenkinder

Schusterjungen und Hurenkinder sind historische Begriffe aus der Typographie, die seit langem benutzt werden. Ein Hurenkind ist die letzte Zeile eines Absatzes, die alleine am oberen Rand der nächsten Seite steht. Ein Schusterjunge ist dagegen die erste Zeile eines Absatzes, die alleine am unteren Rand der Vorseite steht. Mit einem Textdokument von LibreOffice können Sie diese unschönen Erscheinungen automatisch für die gewünschte Absatzvorlage vermeiden. Dabei können Sie sogar wählen, wie viele Zeilen mindestens immer zusammen auf einer Seite gehalten werden sollen.

RTF

RTF (Rich Text Format) ist ein für den Austausch von Textdateien entwickeltes Dateiformat. Es zeichnet sich dadurch aus, dass Formatierungsinformationen in direkt lesbare Textdaten konvertiert werden. Leider entstehen dabei im Vergleich zu anderen Formaten recht große Dateien.

Relationale Datenbank

Ein RDBMS (relational database management system) ist ein Datenbanksystem, in dem Daten in Form miteinander verbundener Tabellen verwaltet werden. DIe Daten können in verschiedener Weise abgefragt werden, ohne dass die zugrundeliegenden Tabellen reorganisiert werden müssen.

Ein relationales Datenbankverwaltungssystem (RDBMS) ist ein Programm, mit dem Sie relationale Datenbanken erstellen, aktualisieren und verwalten können. Ein RDBMS akzeptiert SQL-Anweisungen, die entweder vom Benutzer eingegeben werden oder in einer Anwendung enthalten sind, und erzeugt, aktualisiert oder ermöglicht den Zugriff auf Datenbanken.

Als typisches Beispiel lässt sich eine Datenbank mit Kunden-, Verkaufs- und Rechnungstabellen heranziehen. In der Rechnungstabelle sind nicht die eigentlichen Kunden- oder Verkaufsdaten, sondern Referenzen, in Form von relationalen Verknüpfungen oder Relationen, auf die Tabellenfelder mit den entsprechenden Kunden- und Verkaufsdaten (z. B. das Kundennummernfeld aus der Kundentabelle) enthalten.

Registerhaltigkeit

Registerhaltigkeit ist ein Begriff aus der Typographie. Darunter versteht man den deckungsgleichen Abdruck der Zeilen eines Satzspiegels auf der Vorder- und Rückseite von Büchern, Zeitschriften und Zeitungen. Mit der Funktion Registerhaltigkeit können diese Seiten einfacher gelesen werden, indem verhindert wird, dass graue Schatten durch die Textzeilen hindurchscheinen. Von Zeilenregisterhaltigkeit spricht man auch dann, wenn sich bei Textspalten alle nebeneinanderliegenden Zeilen auf gleicher Höhe befinden.

Wenn Sie einen Absatz, eine Absatzvorlage oder eine Seitenvorlage als registerhaltig definieren, werden die Grundlinien der betroffenen Zeichen an einem vertikalen Seitenraster ausgerichtet. Dabei spielt die Schriftgröße oder das Vorhandensein einer Grafik keine Rolle. Sie können die Einstellung für dieses Raster auch als eine Seitenvorlagen-Eigenschaft festlegen.

Primärschlüssel

Ein Primärschlüssel dient zur eindeutigen Kennzeichnung eines Datenbankfeldes. Diese eindeutige Identifikation von Datenbankfeldern wird bei relationalen Datenbanken verwendet, bei denen von einer Tabelle auf die Daten einer anderen Tabelle zugegriffen werden kann. Wird von einer anderen Tabelle auf einen Primärschlüssel verwiesen, so bezeichnet man ihn als Fremdschlüssel.

In LibreOffice definieren Sie Primärschlüssel in der Entwurfsansicht einer Tabelle, indem Sie im Kontextmenü eines Zeilenkopfes für das ausgewählte Feld den entsprechenden Befehl wählen.

PNG

PNG (Portable Network Graphics) ist Grafikdateiformat. Die Dateien werden mit einem wählbaren Faktor und, im Gegensatz zu JPG, stets verlustfrei komprimiert.

OpenGL

OpenGL ist eine ursprünglich von SGI (Silicon Graphics Inc) entwickelte 3D-Grafiksprache. Zwei Varianten dieser Sprache sind weit verbreitet: das auf die Verwendung unter Windows NT ausgerichtete Microsoft OpenGL und Cosmo OpenGL von SGI. Cosmo OpenGL ist eine für alle Plattformen und Computertypen geeignete, unabhängige Grafiksprache, die sogar auf Systemen ohne spezielle 3D-Grafikhardware eingesetzt werden kann.

OLE

OLE steht für Object Linking and Embedding, also etwa Verknüpfung und Einbettung von Objekten. OLE-Objekte können wahlweise als Verknüpfung in ein Dokument eingefügt oder selbst darin eingebettet werden. Beim Einbetten wird eine Kopie des Objekts zusammen mit Angaben zum Quellprogramm in das Zieldokument eingefügt. Wenn Sie das Objekt bearbeiten möchten, müssen Sie nur darauf doppelklicken und aktivieren so das Quellprogramm.

ODBC

Open Database Connectivity (ODBC) ist ein Protokoll für den Zugriff auf Datenbanksysteme durch Anwendungen. Dabei kommt die Abfragesprache SQL (Structured Query Language) zum Einsatz. In LibreOffice können Sie von Fall zu Fall entscheiden, ob die Abfragen durch Eingabe von SQL-Befehlen oder anhand der interaktiven Hilfe erfolgen sollen. Bei letzterer Methode definieren Sie die Abfrage per Mausklick und LibreOffice übersetzt sie dann automatisch in SQL.


Objekt

Ein Objekt ist ein Element auf dem Bildschirm, das Informationen enthält. Dabei kann es sich z. B. um Anwendungsdaten handeln, wie Texte oder Grafiken.

Objekte sind selbstständig und beeinflussen sich nicht gegenseitig. Jedem Objekt, das Daten enthält, werden bestimmte Befehle zugeordnet. Ein Grafikobjekt wird so mit Befehlen zur Bildbearbeitung versehen, ein Tabellendokument mit Befehlen zur Berechnung usw.

Kontextmenü

Um das Kontextmenü eines Objekts zu aktivieren, wählen Sie das Objekt zunächst durch Klicken mit der linken Maustaste aus und klicken dann mit der rechten Maustaste. Einige Kontextmenüs lassen sich auch dann aufrufen, wenn das Objekt nicht ausgewählt ist. Nahezu überall in LibreOffice sind Kontextmenüs vorhanden.

Kerning

Kerning ist die englische Bezeichnung für Unterschneiden und Spationieren. Darunter versteht man das Verringern oder Vergrößern des Abstandes zwischen Buchstabenpaaren zum optischen Ausgleich des Schriftbildes, z. B. bei W und a.

In Kerning-Tabellen ist vermerkt, welche Buchstabenpaare mehr Abstand benötigen. Diese Tabellen sind in der Regel Bestandteil der jeweiligen Schrift.

JDBC

Sie können die API der Java Database Connectivity (JDBC) zum Herstellen einer Verbindung mit einer Datenbank von LibreOffice verwenden. JDBC-Treiber sind in der Programmiersprache Java geschrieben und plattformunabhängig.

Formatierung

Unter Formatieren versteht man in diesem Zusammenhang das optische Gestalten von Texten mit einem Textverarbeitungs- oder DTP-Programm. Dazu gehören das Festlegen des Papierformats, der Seitenränder, der Schriftarten, der Schrifteffekte sowie der Einzüge und Abstände. Sie können Text direkt bei der Eingabe oder mithilfe der Formatvorlagen in LibreOffice formatieren.

Drehfeld

  1. Ein Drehfeld ist eine Eigenschaft eines Zahlen-, Währungs, Datums- oder Zeitfelds bei Formular-Steuerelementen. Wenn die Eigenschaft "Drehfeld" aktiviert ist, zeigt das Feld zwei Symbole mit Pfeilen an. Diese zeigen entweder senkrecht oder waagerecht in entgegengesetzte Richtungen.
  2. In der Basic IDE wird ein numerisches Feld mit zwei Pfeilsymbolen als Drehfeld bezeichnet.

Sie können entweder direkt in das Drehfeld einen numerischen Wert eingeben oder mit dem Auf- oder Abwärtspfeil auswählen. Mit der Auf- und der Abwärtspfeiltaste Ihrer Tastatur lässt sich der Wert im Drehfeld vergrößern oder verkleinern. Mit den Tasten (Bild auf) und (Bild ab) können Sie den Höchst- und den Mindestwert für das Drehfeld festlegen.

Handelt es sich um ein Drehfeld für numerische Werte, dann können Sie auch eine Maßeinheit angeben, also z. B. 1 cm oder 5 mm oder 12 pt oder 2".

DDE

DDE steht für "Dynamic Data Exchange", also den dynamischen Datenaustausch. Dies ist ein Vorgänger von OLE, dem "Object Linking and Embedding". Bei DDE werden die Objekte in Form von Verknüpfungen zu Dateien eingebunden, aber im Gegensatz zu OLE nicht selbst eingebettet.

DDE-Verknüpfungen lassen sich wie folgt erzeugen: Wählen Sie in einem LibreOffice Calc-Tabellendokument Zellen aus, kopieren Sie sie in die Zwischenablage, wechseln Sie in ein anderes Tabellendokument und wählen Sie im Menü Bearbeiten - Inhalte einfügen. Wählen Sie die Option Verknüpfen aus, um den Inhalt als DDE-Verknüpfung einzufügen. Bei Aktivierung der Verknüpfung wird der eingefügte Zellbereich aus der Originaldatei eingelesen.

Complex Text Layout (CTL)

Sprachen mit komplexen Skripten können unter anderem folgende Eigenschaften aufweisen:

  • Es werden Zeichen verwendet, die aus mehreren Teilen zusammengesetzt sind
  • Die Schreibrichtung des Texts läuft von rechts nach links.

LibreOffice unterstützt derzeit Hindi, Thai, Hebräisch und Arabisch als CTL-Sprachen.

Aktivieren Sie die CTL-Unterstützung im Menü unter Extras - Optionen...' - Spracheinstellungen - Sprachen'.

Bézierobjekt

Bézierkurven sind nach einem von dem französischen Mathematiker Pierre Bézier entwickelten Verfahren mathematisch dargestellte Kurven, wie sie in zweidimensionalen Grafikanwendungen zum Einsatz kommen. Eine solche Kurve definiert sich durch vier Punkte: den Anfangspunkt, den Endpunkt und zwei separate Zwischenpunkte. Bézierobjekte lassen sich durch Verschieben dieser Punkte mit der Maus verformen.

ASCII

Abkürzung für American Standard Code for Information Interchange. ASCII ist ein Zeichensatz für die Zeichendarstellung bei Personal Computern. Er besteht aus 128 Zeichen mit Buchstaben, Ziffern, Satzzeichen sowie Sonderzeichen. Der erweiterte ASCII-Zeichensatz enthält 256 Zeichen. Jedem Zeichen ist eine eindeutige Nummer zugewiesen, die man auch als ASCII-Code bezeichnet.

In HTML-Seiten sollten nur die Zeichen des 7-Bit-ASCII-Zeichensatzes vorkommen. Andere Zeichen, wie etwa die deutschen Umlaute, werden durch Umschreibungen gekennzeichnet. So wird das kleine "ü" etwa zu "ü". Sie können Zeichen im erweiterten ASCII-Code eingeben: Der LibreOffice-Exportfilter sorgt für die erforderliche Umwandlung.

Andocken

Einige Fenster in LibreOffice, zum Beispiel das Formatvorlagenfenster und der Navigator, sind "andockbare" Fenster. Sie können diese Fenster verschieben, vergrößern oder sie an eine Kante des Arbeitsbereichs andocken. An jeder Kante können Sie mehrere Fenster über, oder nebeneinander andocken. Sie können dann durch das Verschieben der Umrandungslinien die relativen Proportionen der Fenster verändern.

Zum Ab- und wieder andocken halten Sie die Strg-Taste gedrückt und klicken doppelt in einem freien Fensterbereich. Im Formatvorlagenfenster können Sie auch doppelt in einem grauen Teil des Fensters nahe der Symbole klicken, während Sie die Strg-Taste gedrückt halten.

Andocken (AutoHide)

An jedem Fensterrand, an dem ein anderes Fenster angedockt ist, befindet sich eine Schaltfläche, die zum Einblenden oder Ausblenden des Fensters dient.

  • Wenn Sie zum Anzeigen des Fensters auf die Schaltfläche am Fensterrand klicken, bleibt das Fenster so lange eingeblendet, bis Sie es mit derselben Schaltfläche wieder ausblenden.
  • Wenn Sie das Fenster durch Klicken auf den Fensterrand einblenden, aktivieren Sie die Funktion AutoHide. AutoHide ermöglicht es, ein eigentlich ausgeblendetes Fenster durch Klicken auf dessen Rand kurzzeitig einzublenden. Sobald Sie den Mauszeiger aus dem Fensterbereich bewegen, wird das Fenster wieder verborgen.

Direkte und indirekte Formatierungen

Wenn Sie Ihre Dokumente ohne Hilfe von Formatvorlagen formatieren, spricht man von direkter oder "harter" Formatierung. Darunter versteht man die Veränderung von Texten oder anderen Objekten, wie Rahmen oder Tabellen, über die Zuweisung verschiedener Attribute. Die Formatierung gilt nur für den ausgewählten Bereich; und alle Änderungen müssen einzeln bearbeitet werden. Indirekte oder "weiche" Formatierungen dagegen nehmen Sie nicht am Text vor, sondern durch Zuweisen von Formatvorlagen. Der große Vorteil besteht darin, dass Sie mit der Änderung einer Formatvorlage alle Objekte (Absätze, Rahmen, usw.) ändern, denen Sie diese Formatvorlage zugewiesen haben.

Direkte Formatierungen können Sie aus Ihrem Dokument entfernen, indem Sie mit der Tastenkombination Strg+A alles auswählen und dann den Menübefehl Format - Direkte Formatierung löschen wählen.

IME

IME ist eine Abkürzung für Input Method Editor, also Eingabemethoden-Editor. Dies ist ein Programm, das die Eingabe von komplexen Zeichen aus nichtwestlichen Zeichensätzen über eine Standardtastatur ermöglicht.