Konwersja dokumentów Microsoft Office

From LibreOffice Help
Jump to: navigation, search

Pakiet LibreOffice może automatycznie otwierać dokumenty Microsoft Office 97/2000/XP. Jednak w przypadku bardziej złożonych dokumentów pakietu Microsoft Office niektóre funkcje układu i atrybuty formatowania są interpretowane inaczej w pakiecie LibreOffice albo nie są przez niego obsługiwane. W efekcie przekonwertowane pliki wymagają wykonania pewnych ręcznych czynności formatujących. Ilość wymaganych zmian formatowania jest proporcjonalna do stopnia złożoności struktury i formatowania dokumentu źródłowego. W pakiecie LibreOffice nie można uruchomić skryptu Visual Basic, ale można je załadować w celu przeanalizowania.

Note.png Najnowsze wersje LibreOffice mogą wczytywać i zapisywać dokumenty w formacie Microsoft Office Open XML, są to pliki z rozszerzeniami docx, xlsx i pptx. W tych wersjach możliwe jest również uruchomienie niektórych skryptów Excel Visual Basic, jeśli ta funkcja zostanie włączona w Narzędzia - Opcje' - Ładuj/Zapisz - Właściwości VBA'.

Następujące listy zawierają ogólne zestawienie funkcji pakietu Microsoft Office, które mogą sprawiać problemy podczas konwersji. Te problemy nie uniemożliwiają korzystania lub pracy z zawartością przekonwertowanych dokumentów.

Microsoft Word

  1. Autokształty
  2. Poprawki
  3. Obiekty OLE
  4. Niektóre formanty i pola formularzy Microsoft Office
  5. Indeksy
  6. Tabele, ramki oraz formatowanie wielokolumnowe
  7. Hiperłącza i zakładki
  8. Grafiki Microsoft WordArt
  9. Znaki lub tekst animowany

Microsoft PowerPoint

  1. Autokształty
  2. Odstępy między tabulatorami, wierszami i akapitami
  3. Wzorce grafiki tła
  4. Pogrupowane obiekty
  5. Niektóre efekty multimedialne

Microsoft Excel

  1. Autokształty
  2. Obiekty OLE
  3. Niektóre formanty i pola formularzy Microsoft Office
  4. Tabele przestawne
  5. Nowe typy wykresów
  6. Formatowanie warunkowe
  7. Niektóre funkcje/formuły (patrz poniżej)

Jednym z przykładów różnić między programami Calc i Excel jest sposób obsługi wartości logicznych. W komórkach A1 i A2 wpisz wartości PRAWDA.

  • W programie Calc zwrócenie wartości 2 spowoduje formuła =A1+A2, a także formuła =SUMA(A1;A2).
  • W programie Excel formuła =A1+A2 spowoduje zwrócenie wartości 2, ale formuła =SUMA(A1,A2) - wartości 0.
Note.png Szczegółowe informacje na temat konwersji dokumentów do formatów i z formatów pakietu Microsoft Office, patrzMigration Guide.

Otwieranie dokumentów pakietu Microsoft Office chronionych hasłem

LibreOffice może otwierać następujące typy dokumentów Microsoft Office chronione hasłem.

Format Microsoft Office Obsługiwana metoda szyfrowania
Word 6.0, Word 95 Słabe szyfrowanie XOR
Word 97, Word 2000, Word XP, Word 2003 Szyfrowanie zgodne z pakietem Office 97/2000
Word XP, Word 2003 Słabe szyfrowanie XOR z wcześniejszych wersji programu Word
Excel 2.1, Excel 3.0, Excel 4.0, Excel 5.0, Excel 95 Słabe szyfrowanie XOR
Excel 97, Excel 2000, Excel XP, Excel 2003 Szyfrowanie zgodne z pakietem Office 97/2000
Excel XP, Excel 2003 Słabe szyfrowanie XOR z wcześniejszych wersji programu Excel

Pliki Microsoft Office, które są szyfrowane AES128 mogą być otwierane. Inne metody szyfrowania nie są obsługiwane.


Related Topics

Korzystanie z dokumentów Microsoft Office w pakiecie LibreOffice

Zmiana przypisania plików Microsoft Office

Ustawianie domyślnego formatu plików