Import et export de fichiers texte

From LibreOffice Help
Jump to: navigation, search

Les fichiers CSV (valeurs séparées par une virgule) sont des fichiers texte dont le contenu est celui des cellules d'une feuille. Vous pouvez utiliser des caractères tels que la virgule ou le point-virgule comme séparateurs de champ entre les cellules. Les chaînes de texte sont placées entre guillemets contrairement aux nombres.

Pour importer un fichier CSV

  1. Choisissez Fichier - Ouvrir.
  2. Dans le champ Type de fichier, sélectionnez le format "Texte CSV". Sélectionnez le fichier et cliquez sur Ouvrir. Quand l'extension du fichier est .csv, le type de fichier est automatiquement reconnu.
  3. Vous verrez la boîte de dialogue Import de texte. Cliquez sur OK.
Tip.png Si le fichier csv contient des formules et que vous souhaitez importer le résultat de ces formule, alors choisissez Outils - Options' - LibreOffice Calc - Affichage' et décochez la case Formules.

Pour exporter des formules et valeurs comme fichiers CSV

  1. Cliquez sur la feuille à enregistrer en tant que fichier csv.
  2. Procédez comme suit pour exporter des formules en tant que telles (=SOMME(A1:B5), par exemple) :

    Choisissez Outils - Options' - LibreOffice Calc - Affichage'.

    Sous Affichage, cochez la case Formules. Cliquez sur OK.

    Si vous voulez exporter le résultat des calculs et non les formules, ne cochez pas la case Formules.
  3. Choisissez Ficher - Enregistrer sous. Vous verrez la boîte de dialogue Enregistrer sous.
  4. Dans le champ Type de fichier, sélectionnez le format "Texte CSV".
  5. Saisissez un nom et cliquez sur Enregistrer.
  6. Dans la boîte de dialogue Export de texte qui s'affiche, sélectionnez le jeu de caractères ainsi que les séparateurs de champ et de texte des données à exporter, puis confirmez vos choix en cliquant sur OK.
  7. Une fois l'enregistrement effectué, annulez le cas échéant la marque du champ Formules pour obtenir de nouveau l'affichage des résultats calculés dans la feuille.

Related Topics

Ouverture et enregistrement de fichiers texte CSV

Outils - Options - LibreOffice Calc - Affichage

Export de fichiers texte

Import de fichiers texte