匯入與匯出 CSV 檔案

From LibreOffice Help
Jump to: navigation, search

逗號分隔值 (CSV) 是文字檔格式,可用於交換資料庫中的資料或在應用程式之間交換試算表。文字 CSV 檔案中的每行代表資料庫中的一項記錄或試算表中的一列。資料庫記錄中的每個欄位或試算表列中的儲存格通常由逗號分隔。但是您可以使用其他字元分隔欄位,例如定位鍵字元。

若欄位或儲存格的內容包含逗號,則必須由單引號 (') 或雙引號 (") 包含欄位或儲存格的內容。

若要在 Calc 中開啟文字 CSV 檔案

  1. 選擇 [檔案] - [開啟舊檔]
  2. 尋找要開啟的 CSV 檔案。

    如果檔案有 *.csv 副檔名則選取該檔案。

    若 CSV 檔案有其他副檔名,請選取檔案,然後在 [檔案類型] 方塊中選取「文字 CSV」。
  3. 按一下 [開啟舊檔]

    [匯入文字] 對話方塊會隨即開啟。
  4. 指定要將檔案中文字分成欄的選項。

    您可以在 [匯入文字] 對話方塊的底端預覽匯入資料的版面配置。

    在預覽中的欄上按一下滑鼠右鍵,可設定格式或隱藏該欄。

    核取符合檔案中用作文字分隔符之字元的文字分隔符方塊。若是未列出的分隔符,請在輸入方塊中鍵入字元。
  5. 按一下 [確定]

將試算表另存為文字 CSV 檔案

Note.png 將試算表匯出成 CSV 格式時,只會儲存目前試算表上的資料。所有其他資訊 (包括公式和格式) 都會遺失。
  1. 開啟您要另存為文字 CSV 檔案的 Calc 試算表。

    只能匯出目前的試算表。
  2. 選擇 [檔案] - [另存新檔]
  3. [檔案名稱] 方塊中,輸入檔案的名稱。
  4. [檔案類型] 方塊中,選取「文字 CSV」。
  5. (可選擇的) 設定文字 CSV 檔案的欄位選項。

    選取 [編輯篩選設定]

    [匯出文字檔] 對話方塊中選取您要的選項。

    按一下 [確定]
  6. 按一下 [儲存]

Related Topics

匯入與匯出具有公式的 CSV 文字檔

對 Base 匯入及匯出資料

[工具] - [選項] - [LibreOffice Calc] - [檢視]

匯出文字

匯入文字