Functie AANTALLEN.ALS

From LibreOffice Help
Jump to: navigation, search

AANTAL.ALS-functie

Geeft het aantal rijen of kolommen die aan criteria in meerdere bereiken voldoen.

Syntaxis

AANTALLEN.ALS(Bereik1; Criterium1 [; Bereik2; Criterium2 [; ...]])

Bereik1 – vereist argument. Het is een reeks cellen, een naam van een benoemd bereik of een label van een kolom of een rij met waarden voor het tellen en het zoeken naar de bijbehorende criteria.

Criterium1 – vereist argument. Een voorwaarde in de vorm van expressie of een verwijzing naar een cel met een expressie, die bepaalt welke cellen worden gebruikt om het gemiddelde te berekenen. De expressie kan tekst, cijfers of reguliere expressies bevatten (als dit in de rekenopties is aangezet) of jokertekens (als dit in de rekenopties is aangezet).

Range2 – Optional. Range2 and all the following mean the same as Range1.

Criterium2 – Optioneel. Criterium2 en alle volgenden hebben dezelfde betekenis als Criterium1.

Note.png De logische relatie tussen criteria kunnen gedefinieerd worden als een logische EN (combinatie). Met andere woorden, als en alleen als aan alle opgegeven criteria wordt voldaan, wordt een rij of een kolom in de telling opgenomen.
Het Criterium moet een tekenreeks-expressie zijn, en het Criterium moet tussen aanhalingstekens worden geplaatst ("Criterium"), met uitzondering van de namen van de functies, celverwijzingen en het teken van een samenvoegingsoperator (&).
De operatoren gelijk aan (=), niet gelijk aan (<>) groter dan (>), groter dan of gelijk aan (> =), kleiner dan (<) en kleiner dan of gelijk aan (<=) kunnen worden gebruikt in criterium-argumenten voor de vergelijking van getallen.
De functie kan maximaal 500 argumenten hebben, wat betekent dat u 250 paren van bereik en criteria kunt opgeven.
Note.png Deze functie maakt deel uit van het Open Document Format voor Office Applications (OpenDocument) standaard versie 1.2. (ISO/IEC 26300: 2-2015)
Warning.png Als een cel WAAR bevat, wordt het als 1 behandeld, als een cel ONWAAR bevat - als 0 (nul).
Als bereiken voor Bereik en Critrium ongelijke afmetingen hebben, geeft deze functie FOUT:502.

Voorbeelden

Overweeg de volgende tabel

A B C
1 Productnaam Verkopen Ontvangsten
2 potlood 20 65
3 pen 35 85
4 kladblok 20 190
5 boek 17 180
6 etui niet niet

Eenvoudig gebruik

=AANTALLEN.ALS(B2:B6">=20")

Telt het aantal rijen van het bereik B2:B6 die waarden groter dan of gelijk aan 20 bevatten. Dit geeft 3, omdat de vijfde en zesde rij niet aan het criterium voldoen.

=AANTALLEN.ALS(B2:B6;">=20";C2:C6;">70")

Telt het aantal rijen dat tegelijkertijd waarden groter dan 70 bevatten in het bereik C2:C6 en waarden groter dan of gelijk aan 20 in het bereik B2:B6. Dit geeft 2, omdat de tweede, de vijfde en de zesde rij niet voldoen aan tenminste één criterium.

Met behulp van reguliere expressies en geneste functies

=AANTAL.ALS(B2:B6;"[:Alpha:]*")

Telt het aantal rijen in het bereik B2:B6 die alleen alfabetische symbolen bevatten. Dit geeft 1, want alleen de zesde rij voldoet aan het criterium.

=AANTAL.ALS(B2:B6;">"&MIN(B2:B6);B2:B6;"<"&MAX(B2:B6))

Telt het aantal rijen in het bereik B2:B6 met uitzondering van rijen die minimum en maximum waarden van dit bereik bevatten. Dit geeft 2, omdat de derde, vijfde en zesde rij niet voldoen aan tenminste één criterium.

=AANTAL.ALS(A2:A6;"pen.*";B2:B6;"<"&MAX(B2:B6))

Telt het aantal rijen die overeenkomen met alle cellen van het bereik A2:A6 die beginnen met "pen" en alle cellen van het bereik B2:B6 met uitzondering van zijn maximum. Dit geeft 1, want alleen de tweede rij voldoet aan alle criteria.

Verwijs naar een cel als een criterium

Als u een criterium gemakkelijk moet kunnen veranderen, kunt u dit in een aparte cel opvoeren en gebruik maken van een verwijzing naar deze cel in de voorwaarde van de AANTAL.ALS-functie. De bovenstaande functie kan bijvoorbeeld als volgt worden herschreven:

=AANTAL.ALS(A2:A6;E2&".*";B2:B6;"<"&MAX(B2:B6))

Als E2 = pen, geeft de functie 1, omdat de verwijzing naar de cel wordt vervangen met de inhoud ervan en het werkt als een hierboven genoemde functie.


Related Topics

AANTAL, AANTAL.ALS, AANTAL.A, SOM.ALS

, GEMIDDELDE.ALS

, MAX, MIN

Lijst met reguliere expressies