オートフィルターを使う

From LibreOffice Help
Jump to: navigation, search

オートフィルタ 機能を使用すると、選択した各列の最初の行にコンボボックスが挿入されます。このコンボボックスから条件を選択して、表示したい行 (レコード) を選択できます。

  1. オートフィルタを使用する列を選択します。
  2. データ → フィルター → オートフィルター を選択します。選択した各列の最初の行にコンボボックスの矢印が表示されます。
  3. 最初の行にある矢印をクリックすると、ドロップダウンリストが現れます。そこからフィルターの条件を選択できます。

    これで、内容がフィルター基準と一致する行のみが表示されました。その他の行はフィルターが適用された状態になっています。行にフィルターが適用されているかどうかは、行番号が連続しているかどうかによって確認できます。フィルターに使用されている列は、矢印付きボタンが別の色になっていることで確認できます。

フィルタリングしたデータ範囲の別の列に追加のオートフィルターを適用すると、別のコンボボックスによってフィルタリングされたデータのみが表示されます。

すべての項目 (レコード) を表示し直すには、AutoFilter コンボボックスの「すべて」を選択します。もし「標準」を選択すると、標準フィルタダイアログが開き、標準フィルタを設定できます。「トップ 10」を選択すると上位 10 個の値を表示します。

オートフィルターの使用を停止するには、手順 1 で選択したすべてのセルを選択し直してから、もう一度、データ → フィルター → オートフィルター を選択します。

Tip.png 異なるシートに異なるオートフィルタを割り当てるには、まずシートごとにデータベース範囲を定義します。
Warning.png 算術関数は、フィルターを適用したために表示されていないセルも計算の対象として使用します。たとえば、列の合計を計算するときには、フィルタリングされたセルの値もすべて計算されます。フィルターを適用した後も表示されるセルのみを使用する場合は、SUBTOTAL 関数を使用します。

Related Topics

フィルターの適用

フィルター: 特殊フィルターを使う

表示されているセルのみのコピー

データ → フィルター → オートフィルター

小計