Direcciones y referencias, absolutas y relativas

From LibreOffice Help
Jump to: navigation, search

Referencia relativa

A1 hace referencia a la celda en la columna A y fila 1. La referencia a un área contigua se consigue indicando la esquina superior izquierda del área, luego dos puntos y finalmente la celda inferior derecha del área. El área cuadrada de las primeras cuatro celdas en la esquina superior izquierda se llamaría de este modo A1:B2.

En esta forma de referencia a un área, la referencia a A1:B2 será una referencia relativa. Relativa significa en este contexto que la referencia se ajusta al área al copiar las fórmulas.

Referencia absoluta

En oposición a las referencias relativas existen las referencias absolutas que se escriben de la siguiente forma: $A$1:$B$2. Delante de cada dato usado como absoluto deberá figurar el signo del dólar.

Tip.png LibreOffice puede transcribir, en la línea de entrada actual, todas las referencias relativas a absolutas y viceversa si pulsa la combinación de teclas (Mayús) (F4). Si comienza con una dirección relativa como A1, ocurre lo siguiente: Con la primera pulsación las filas y columnas se convertirán en absolutas ($A$1); con la siguiente lo hará sólo la fila (A$1), luego sólo la columna ($A1), y después se convertirán ambas de nuevo en relativas (A1).

LibreOffice Calc le muestra de manera esquemática las referencias a una fórmula. Si pulsa p.ej. en una celda sobre la fórmula =SUMA(A1:C5;D15:D24), ambas áreas referenciadas se destacarán en color. La parte de la fórmula "A1:C5" puede p.ej. aparecer en azul y el marco del área de celda referenciada en un tono azul. La siguiente parte de la fórmula "D15:D24" puede aparecer seleccionada de forma semejante en rojo.

¿Cuándo usar referencias relativas y cuándo absolutas?

¿Cómo se distingue una referencia relativa? Supongamos que desea calcular en la celda E1 la suma de las celdas en el área A1:B2. La fórmula que debe introducir en E1 debe ser: =SUMA(A1:B2). Si más tarde decide insertar una columna nueva delante de la columna A, los elementos que quiere sumar aparecerán entonces en B1:C2 y la fórmula en F1, en lugar de en E1. Por consiguiente, tras insertar la nueva columna, debería comprobar y corregir todas las fórmulas de la hoja, y posiblemente en otras hojas.

Afortunadamente, LibreOffice se encarga de ello. Después de insertar una nueva columna A, la fórmula =SUMA(A1:B2) se actualiza a =SUMA(B1:C2) de forma automática. Los números de fila también se ajustan automáticamente al insertar una nueva fila 1. Las referencias absolutas y relativas se ajustan en LibreOffice Calc siempre que se desplaza el área a la que se hace referencia. Tenga cuidado, no obstante, al copiar una fórmula, ya que en ese caso únicamente se ajustan las referencias relativas, no las absolutas.

Las referencias absolutas se utilizan cuando un cálculo hace referencia a una celda específica de la hoja. Si una fórmula que hace referencia precisamente a esa celda se copia a una celda situada más abajo que la original, la referencia se desplazará hacia abajo si no se han definido las coordenadas como absolutas.

Aparte de con la inserción de nuevas filas y columnas, las referencias también pueden cambiar si una fórmula que hace referencia a celdas específicas se copia en otra área de la hoja. Suponiendo que ha introducido la fórmula =SUMA(A1:A9) en la fila 10, si desea calcular la suma de la columna adyacente a la derecha, sólo tiene que copiar esta fórmula en la celda de la derecha. La copia de la fórmula en la columna B se ajustará automáticamente para obtener =SUMA(B1:B9).


Related Topics

Dar nombre a celdas

Reconocer un nombre como referencia